🏠 back to Observable

Broken login?

Hi there, I created an account via my GitHub account way back. I just tried logging in and (after a bit of awkwardness with oAuth) it logs in but won’t let me access the site anything other than try to force me to select a username as if I was creating a new account. Naturally, my normal username is ‘taken’ becase I’m already using it; have I now somehow got two accounts connected to the same GitHub?

Is there anything I can do to fix this, or to regain access to my original account?

Thanks

Hi @CodeMacabre welcome back to Observable & welcome to the forum!

Sorry to hear you’ve had trouble logging in. We recently made some improvements to our login flow that changed the login UI slightly. To log in now you need to:

  1. Click the “Sign In” button in the top right corner on https://observablehq.com

  2. Enter the Observable username you chose when you signed up (it sounds like you remember your username, but you can also click “Forgot username” to recover it with your email to confirm it’s what you think it is)

  3. Click the button to use whichever authentication service (e.g. GitHub) you originally used to create your account.

You can read more about the changes & see a walkthrough video here: https://observablehq.com/@observablehq/login-improvements

If it still doesn’t work for you, email support@observablehq.com with your details and we will investigate!

Thanks @anjana, unfortunately I’m still having some issues (I now appear to have two accounts connected to my GitHub account). I’ll send an email.

Looking into it as we speak - will follow up via email!

1 Like

Thank you @anjana! All sorted!

If anyone else has a similar issue, it seems it may have been caused by me tinkering with my GitHub account name or something along those lines. :man_shrugging:t3:

1 Like