🏠 back to Observable

Weird logged in/not logged in problems

I’ve a personal account that I sign in to with GitHub, and for some reason some pages see me as logged in and able to view unpublished notebooks just fine, while other pages (like the notebook list page) refuses to believe I’m logged in and will not let me log in. The only error in console that I see when I try to log in is:

[Error] Failed to load resource: Could not connect to the server. (analytics.js, line 0) https://www.google-analytics.com/analytics.js

I’ve tried clearing cache. I’ve not tried blowing away cookies yet as I didn’t want to lose all access.

Thoughts?

We will look into it. Thanks for flagging.

1 Like

FWIW, I thought it could be that I’ve got network-wide ad blocking so I tethered to my phone instead, but same result. I am logged in to GitHub just fine.

If I visit some of my unpublished pages by using bookmarks, it kind of works but I’m seeing HTTP 401 (unauthorized).

Whelp… logged out so I could try “starting fresh” and logging back in. No joy. Attempting to log in just loops me back to the noon-logged-in home page, logged out.

I also tried removing all local storage and logging in… same.

Safari on Mac, Version 14.1.1 (15611.2.7.1.6, 15611)

Moved over to Firefox and was able to log in just fine and things appear to be working normally.

FWIW, also seeing this once in a while lately (a few times a day, for sure).

In this case I’m simply viewing the Introduction to HTML page.

The notebook is not open in another tab.

Hmm, I wonder if there’s something strange with your cookie, and it’s in a semi-broken state? I think the next step would be to delete all cookies for observablehq.com and log in again. I wonder if there’s something out of sync with your cookies and even logging out didn’t fully do it.

It’s possible this is an unrelated issue, hard to say. Are there any console errors when this happens?

We have code in place that’s supposed to detect these sorts of performance issues before the browser does and provides more contextual options for recovering, but it’s not working in your case FWIW I tested in Safari 14.1.1 just now on that notebook and it works fine for me, so there’s something more nuanced happening that’s causing your issues, unfortunately.

Yeah, I did delete all cookies back at the “Whelp…” reply.

Update: It was something with Safari. What, I don’t know. But I rebooted the Mac and all is working as expected. Sorry for the non-interesting issue report.

I’m glad you got it to work! Web technology can be a strange, fickle thing sometimes :joy: