🏠 back to Observable

Oops, an unexpected error occured (when logged in and visiting home page)

When I login and switch to my home page, loading takes forever. Page only shows the grey ghost images. Sometimes it shows thumbnails in Recent Notebooks yet after a few seconds those are replaced by an otherwise blank page with the message Oops, an unexpected error occured.

When showing timeline console, timeline goes on forever (i.e. page never seems to fully load and complete).

Does not happen when I’m logged out.

Safari 14.0, Chrome 86.0.4240.111, Firefox 80.0.1!

Screenshot 2020-11-04 at 11.44.14|690x187

Hi Martien. Are you still seeing this problem?

Yes, it’s still there.

Okay, thanks. I’ll add that to the bug report.

@Martien Can you observe the same error when you login in a private/incognito window?

@mootari Hi Fabian, when I login incognito, the list with Recent Activity renders instantaneously, while the header with thumbnails of Recent notebooks takes a long time, but renders correctly.

Makes me wonder.

Any clues?

my best (but still uninformed) guess is that you caught a bad update that got fixed shortly after. Do you still see the issue outside of incognito mode?

Still there in the headers (Recent notebooks).

“Bad update” of what exactly? And is there anything I can do to get back in sync with the good updates?

Of observablehq.com, in any of its sources.

I’d try a hard reload (in Chrome: cmd-shift-r, or shift-click the reload button, or reload while your dev tools are open and “disable cache” is checked in your network tab). If that doesn’t resolve the issue, try logging out and back in.

Tried all your suggestions to no avail.

In Chrome » Performance » Network it seems like continue-editing (api.observablehq.com) takes more than 15s! After it’s done, the three header images show up.

Maybe slow in retrieving the current revision (revision count > 6000)?

That could very well be. I can’t reproduce that though, as the highest version in any of my notebooks is ~2700. Reminds me of this topic:

By the way, if you want to get rid of your history (without creating a fork), and if you’re not relying on your notebook’s internal slug (e.g. by importing it), you could move your code to a new notebook by following these steps.


@dunstan The error handling on the home page could use some improvement. I can reproduce the error described in the opening post by blocking https://api.observablehq.com/user/continue-editing in DevTools. As a result the “Oops, an unexpected error occurred.” error appears.

Since each component on the homepage appears to load independently, there should be a nicer way to handle connection problems.

Right. Happened before, also with one of my notebooks. I know I am a heavy versioner, but still…

In the previous case, an “SQL query which was soaking up the time, and just shipped an optimization that speeds it up by ~100x”.

Sure hope this will be similar (or the issue has regressed.

As for getting rid of my history gives: Oops, an unexpected error occurred.

Catch 22.

Using URL: https://observablehq.com/compare/new...8f3f4aac874ca231

That’s because you haven’t saved the new notebook yet, hence the “new” in the URL.

Great! Thanks, this works. I misread “Create a new notebook, save the first cell.” as “Create a new notebook, except the first cell.” :frowning:

Also thrashed the original. Rendering the three header thumbs still takes a while. Will let it simmer for now.

Funny thing is that it only happens on my Home page, while not at the Notebooks page.

Thanks for helping me out Fabian. :pray:

I’m also running into the same problem. The “Recent Activity” timeline tries to load for about 40s, then the home page gets replaced with Oops, an unexpected error occured. Tried restarting while disabling cache, logging out and back in, opening in incognito, switching to a different browser – the same issue persists. The highest version in any of my notebooks is about 1700.

After some DevTool inspection, the culprit seems to be that a request to https://api.observablehq.com/user/activity?days=7&timezone=Asia%2FHo_Chi_Minh&type=all keeps returning a 503 error. Would love for a way to fix this. Thanks :pray:

(Chrome 86.0.4240.111, Firefox 82.0.2)

I am also seeing the same problem today with the same url giving up with 503 after 30s (https://api.observablehq.com/user/activity but different timezone).

The past few days, my recent activity was often grayed out but without leading to the “Oops” error page.

Any news on this topic @dunstan? Appears like more experience the same problem.

Not yet, sorry. It’s logged as something for engineering to look into as soon as they can.

Okay, thanks. We’ll patiently wait for a resolution.

Let me know if, when, and how I can help.

Thanks Martien. It was actually being worked on, but under another guise, as the problem raised it’s head elsewhere too. I’ll report back once we’ve tracked the issue down. (And thanks for the offer of help.)