It looks like “new” requires new IP addresses to be white-listed for database access… true?
Context: Notebook with a very simple SQL query works fine on old, but on new I get an error:
Error: Error: [libpq] Failed to connect: connection to server at [redacted], port 5432 failed: Connection timed out
Is the server running on that host and accepting TCP/IP connections?
I see this using either Standard Library.
That’s correct; the new database connectors are now serverless functions running on Vercel, so the IP range is different. Vercel supports static IPs and we’ll likely enable this feature soon. Please let us know if this is a requirement for you, thank you.