SQL cells and self hosted database

Hello. I can’t use the SQL cells with self hosted database. A long time ago, I managed to use a local mysql database using this notebook published in 2019. The connexion works. But, it doesn’t work with sql cells. If you have any ideas, I’d love to hear them

1 Like

Not that I can claim to know much of anything about databases, but what happens if you select your already explicitly named DB?

It doesn’t change anything.

Strange. I wish I could help, but this seems to be a bug or something… not sure why the SQL cell wouldn’t work when you’re clearly connected…

Any errors in the JS console? And what do you get when you run a count query on the table?

No error in the console. If I run a count query, nothing appends. But if I query a table that doesn’t exist, the error ER_NO_SUCH_TABLE is returned. Wierd…

If you’re willing to roll up your sleeves even further, you could take a look at the network request that gets sent and inspect the response status and data.

@mootari - Would this be a networking issue? The first post shows that using a non-SQL cell, neocarto can run his query just fine. The problem appears to have something to do with how the SQL cell is interpreting the results… or perhaps I am misinterpreting this?

Did you ever figure this out? If not, looks like a good case for writing to the support team …

No, I have not been able to solve this problem…

I have the same problem, with a self hosted database, too. Although it has an output if I use the DatabaseClient instead of a SQL cell.

1 Like

I have definitely been having this problem. Here’s the description I tweeted a few days ago:

I have a workbook which attempts to do a simple query using a proxied database. Using DatabaseClient(“foo”) and db.query(…) it’s fine, but using a SQL cell I see nothing.

I see “DataCloneError: The object can not be cloned” in Console.

Mac Safari and Chrome.

1 Like

I will notify the support team. Thanks all. This does seem like a bug.


FYI, @mkfreeman has kindly begun taking a look at my report (from the Twitter conversation).

1 Like

Hi all,

Thanks for your patience with this issue - we believe that we’ve identified and resolved the problem. We appreciate that you surfaced the issue, and please let us know if you have further issues!


I still see a similar problem. Using locally hosted observable-database-proxy to a postgres db. When I use db.query() everything runs fine. However, if I use SQL cell with the same db and query I get TypeError: object is not iterable (cannot read property Symbol(Symbol.iterator))


Same thing. Same error message

1 Like

Thanks @zookini + @neocarto - we’ll look into this today!

1 Like

Thanks again @zookini + @neocarto – we identified and fixed the cause of this issue (a change that followed our initial fix). It should be working, but again please let us know if you have any issues.


It works perfectly! Thank you very much.