🏠 back to Observable

Moving cells doesn't seem to work


#1

From the docs:

You can move cells using Alt-Ctrl-Up and Alt-Ctrl-Down

This doesn’t seem to work for me. The cursor sometimes changes into a cross, but nothing moves. I’m using Windows 10 + Chrome.


#2

Hi John!

I’ve updated the other thread about keybindings to note the ones that have changed to avoid Windows-platform-overlap. But this keybinding I’m not sure about - which docs are you quoting? Introduction to notebooks refers to this keybinding as Option-Command-Up which is still the keybinding across platforms (Alt-Command-Up on Windows). Previously we were incorrectly aliasing Command to Ctrl in the help popover, but it will now show Command on both platforms - Windows, the elusive Windows logo key / start key / logo key / flag key / super key / home key.


#3

Hi all,

I am trying Alt + Windows-Key + Up on Windows 10 with Chrome, and cells aren’t moving up and down. Does

anyone know if I’m doing something wrong? Can I send any debug information? I’ve tried many combinations of Alt, Ctrl, Shift, and Windows Key, but most of them have Windows-specific functions , none of my key combinations move cells.

Thanks :slight_smile: Loving Observable

UPDATE What I tried, vs the results:

  • Alt + Windows + Arrow, I see a crosshair cursor symbol (mentioned in other linked post I think), but no moved cells
  • Ctrl + Windows + Arrow swipes screen left to right, but no moved cells
  • Alt + Ctrl + Arrow inverts the screen, but no moved cells

I tried Firefox and Chrome, ( no moved cells in either) and I disabled my screenshotting software in case it was interfering


#4

This thread is a little out-of-date. The current keyboard shortcuts are here:

For non-macOS, the moving cell commands are Control-Shift-Up and Control-Shift-Down.


#5

Thank you, I guess that was the first thing I tried, but it didn’t work; (I see Ctrl+Shift+Up/Down in the tooltips above up/down arrows – very helpful)
I wonder if I’m doing it wrong:

If I have my focus in the Observable cell, as if to edit; Ctrl+Shift+Up/Down will select/deselect my actual Observable text (i.e. same behavior as just holding Shift key)

If try to leave “edit mode” and put focus on the cell more generally, Ctrl+Shift+Up/Down doesn’t do anything;

I will assume it’s something specific to my computer for now, …

UPDATE Tried my partner’s computer, also Windows 10, also Chrome, similar results.


#6

This appears to be a bug on our end… we are investigating!


#7

Thank you


#8

Update: a few of our keyboard shortcuts were unintentionally disabled on non-macOS. The following shortcuts have now been fixed:

macOS non-macOS Description
Option-Command-Up Control-Shift-Up Move the current cell up.
Option-Command-Down Control-Shift-Down Move the current cell down.
Option-Shift-Tab Shift-Alt-Up Focus the previous cell.
Option-Tab Shift-Alt-Down Focus the next cell.

#9

Ctrl+Shift Works for me now, thanks!