Failed to open a private notebook after trying out the new "Comment" feature


I have a private notebook. It’s been working fine until today I could not open it any more. It’s showing “Oops, an unexpected error occurred.”. Opening it in Safe Mode got the same error.

I took a look at the Chrome’s console and network tab. It seemed there was a 500 error response for a GET request.

I remember the last thing I did to this notebook was trying out the new “Comment” feature. I added a comment to one of the cells and then resolved it.

Things became weird after that. Firstly the error banner showed up on top of the page asking me to reload. But after reloading, the notebook just failed to open… :sob:

Maybe I just shouldn’t have added comment to my own notebook??? :frowning:

Any idea how I can troubleshoot/fix this?


Apologies! This was a bug introduced with yesterday’s launch. It should be fixed now. Please let us know if you experience any further errors.

Yay~~ it’s working now! Thanks for the prompt help!!! :slight_smile:

Hi @mbostock, I am currently experiencing the same error ( with chrome console showing the same 500 error on same GET request with a private notebook id).

I can provide the notebook id if needed, let me know

Hi @npjc. I think I’ve fixed your notebook, though possibly one of the cells is in the wrong place and you’ll need to move it. Sorry for the trouble. Is it possible that you had your notebook open in a tab (or possibly more than one tab) since yesterday? Or did this error occur shortly after you opened your notebook in a new window?

Woah thanks. It is definitely possible I had it open in multiple tabs (not intended sorry!).

No apology necessary—it was our fault (and having a notebook open in multiple tabs is AOK)!

1 Like