Unstable notebook failing after a reload or two: Any ideas why?

I have a notebook whose cells randomly give errors:

It’s a hit and miss: sometimes it loads all OK, sometimes it loads with errors in many cells—usually a module error.

I tried running it in multiple browsers, in incognito mode, etc. to no avail; the problem persists.
If you try to reload it a few times, you’d probably see the issue as well, but in case you don’t, here’s a screen recording (the errors appear after a reload or two):

I suspect the issue could be related to the external data sources the notebook uses, but I’m not sure.
After all, it gives a module error and not an error that seems linked to the data fetched.

I would greatly appreciate ideas and any tips on how this notebook can be made stable.

Many thanks in advance!

It looks like you’re using an older version of @mootari’s range-slider notebook, which had an implementation of “lazy” imports that caused require to be unreliable. Try upgrading your import of that notebook (in the Dependency versions pane, or by clicking the lock icon next to that notebook), and try again?

1 Like

yeah that fixes it for me :pray:


Thank you so much for the fast and dead-on answer Mike!
It indeed worked and this was a life-saver.
Very much appreciated!
Good to know what to check next time something like this happens.

1 Like

Thanks a lot for checking it—also fixes it here!