🏠 back to Observable

Editor injects line breaks on save

When saving a cell with long indented lines, the editor will inject a line break (and possibly whitespace). I found no way to avoid this change. Prettier is disabled.

1 Like

In addition, trailing commas also get removed when entering line breaks. This is not great.

When editing a team notebook (which was the case here), only the team-wide Prettier setting is taken into account. Somewhat confusing (because not clear to the user), but very intentional (judging from the code).

2 Likes