deploying a framework project to static site hosts

I tried deploying my framework project on a couple of different static site hosts, and 2 out of 3 didn’t work. I’m now trying to figure out the details of why.

Working: a pretty bare bones Caddy server configured on a linux box I control.
Not working:

I deployed my project basically following
The result is that requests for files configured as data sources for duckdb tables in the top matter of md files receive no response (shown as Pending in dev tools network tab). All remaining assets seem to be served correctly, including files referenced in FileAttachment calls.

When the project’s deployed to, all requests for data files in _file/ return “410 Gone”. All html, js and other assets download with no issue. Of course when deploying, surge reported all files uploaded successfully.

Any ideas?

Yes, I tried reaching out to the operators of those two services - still waiting for a reply.

Can you verify that the files are indeed present in _file/ when you build the project locally?

Sure, first thing I did.
Moreover, as I said I uploaded the entire build/ folder to a server I manage and everything works flawlessly.
Also, note that I am not getting a 404 (or 4** anything). Just no response at all.

Are all your file names lowercase and ascii?

All ascii but not all lowercase.
Hard to imagine that would be a problem…

Not at all:

That sounds like an OS issue. Mine is definitely case sensitive. Anyway, that would manifest itself as a 404, no?

Edit: indeed, when I change the case of some letters in the url of a file that is served properly, the server duly responds with a 404 (talking about here).

I would also recommend to

  1. delete your local build cache, then rebuild and redeploy (to rule out any potential issues on framework’s side)
  2. delete the project at the host and redeploy (since issues around case sensitivity can introduce many subtle bugs wrt file handling)

Did both, made no difference.

Now deployed the very same project to Vercel - no issues, everything works perfectly.