🏠 back to Observable

text doesn't fit in the legend

Hi. My text doesn’t appear to fit in the legend. Screen Shot 2020-07-22 at 10.05.26 AM
This is how it shows on the page, even if I make my svg smaller and have plenty of space for the legend, it still doesn’t show up. When I download PNG, the text still doesn’t show up :confused:

Hi @ChiqueCode. I appreciate your frustration, but it’s really hard to understand exactly what you’re experiencing with just a screen shot. Can you please share a notebook that demonstrates the error?

2 Likes

@aaronkyle Unfortunately, I can’t share my notebook as it has a sensitive data. What I am trying to figure out is why does the field name for one of my data points doesn’t display the whole text. Here is my code:
vegalite({
width: 800,
height: 300,
data: { values: AdPitchedInd },
mark: ‘bar’,
encoding: {
x: {
aggregate: “sum”,
field: “ad_pitched_value_occurence”,
type: “quantitative”,
scale: { domain: [0, 360], nice: false }
},
y: { field: “industry”, type: “nominal” },
color: { field: “ad_pitched”, type: “nominal” }
},
config: {
legend: {
orient: “top”
}
}
})```

So field ad_pitched has a value and in the legend this value only shows the first x letters, where I need an entire string to be displayed…

Can you share a fork of your notebook where the data is replaced with mocked up data that demonstrates the issue (two to three entries should probably suffice)? Alternatively, can you create a reduced version of your notebook that shows the problem?