require & versions

I have a question regarding the require function. I don’t understand which version of the module is loaded. Here are 2 examples

require.resolve(“geotoolbox@1”) => 1.9.5 (OK)
require.resolve(“geotoolbox”) => 1.9.3 (NOT OK)
require.resolve(“geotoolbox@latest”) => 1.9.3 (NOT OK)


require.resolve(“bertin@1”) => 1.6.4 (OK)
require.resolve(“bertin”) => 1.6.3 (NOT OK)
require.resolve(“bertin@latest”) => 1.6.4 (OK)


Since you published 1.9.4 and 1.9.5 only a few hours ago, I suspect that you’re seeing cached responses (the max age is 12 hours). If, for example, you take a look at jsdelivr you’ll see that it still lists 1.9.3 as the most recent version.

Ok. That’s what I suspected. Thx.