🏠 back to Observable

Embedding Issue - Troubleshoot

Problem

I followed How to Embed a Notebook in React and everything works great in development. When I try to deploy my site to Netlify I get an NPM EINTEGRITY error due to sha-512 checksums that don’t match. It looks like the Gatsby build process is looking for the sha-512 that appears in both the Observable notebook tarball package and the package-lock.json file but gets a totally different sha-512. This error causes the build and the deploy to fail.

I tend to think this has something to do with the Gatsby webpack bundling but I figured I would post here first.

Sorry I am still learning how Observable notebook works work. Any help is appreciated.


Update

So I found a partial solution.

I had already updated my node and npm versions to match those of the Netlify build image. I had already deleted my local node modules folder and package-lock.json file and tried re-running npm i. I was still getting the same error.

I decided to remove package-lock.json from the deploy and that worked. I don’t know if this is the best solution but I was going crazy trying stuff.

1 Like